Grizzly 2.3 release date and Servlet dependencies

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Grizzly 2.3 release date and Servlet dependencies

Matthew Swift-3
Hi there,

We've just noticed that Servlet 3.1b03 onwards require JDK7[1].  I'm not sure if this is an intentional change since 3.1 b01 required only JDK5, but it will have implications for Grizzly and any applications and libraries which use Grizzly 2.3 HTTP Servlet onwards, since they will be required to use JDK7. Were you aware of these changes?

Also, once 2.3 is released will it be possible to use it with Servlet 3.0 instead of 3.1? This question is less important if Servlet 3.1 is reverted back to supporting JDK6.

Finally, when is the expected release date for Grizzly 2.3?

Cheers! :-)

Matt
Reply | Threaded
Open this post in threaded view
|

Re: Grizzly 2.3 release date and Servlet dependencies

oleksiys
Administrator
Hi Matt.

On 20.03.13 04:26, Matthew Swift wrote:
Hi there,

We've just noticed that Servlet 3.1b03 onwards require JDK7[1].  I'm not sure if this is an intentional change since 3.1 b01 required only JDK5, but it will have implications for Grizzly and any applications and libraries which use Grizzly 2.3 HTTP Servlet onwards, since they will be required to use JDK7. Were you aware of these changes?
Yes, we were :)
Unfortunately Servlet 3.1 API introduced this dependency, so we have to follow if we want to support it.


Also, once 2.3 is released will it be possible to use it with Servlet 3.0 instead of 3.1? This question is less important if Servlet 3.1 is reverted back to supporting JDK6.
We'll try to compile/deliver 2.3 servlet module with JDK 1.6 as target. So it'll be possible to use Grizzly 2.3 servlet module and Servlet 3.0 API on JDK6 (I need to doublecheck that).

Finally, when is the expected release date for Grizzly 2.3?
We want to integrate 2.3 to Glassfish 4 and hardcode freeze for Glassfish 4 is next Monday... so we'll release 2.3 this week or early next week :)

Thanks.

WBR,
Alexey.


Reply | Threaded
Open this post in threaded view
|

Re: Grizzly 2.3 release date and Servlet dependencies

Matthew Swift-3
Hi Alexey,

Thanks for the quick response and the confirmation regarding JDK6/Servlet3.0  interop. I look forward to trying and testing Grizzly 2.3 very soon then! :-)

Matt



On 21 March 2013 09:11, Oleksiy Stashok <[hidden email]> wrote:
Hi Matt.


On 20.03.13 04:26, Matthew Swift wrote:
Hi there,

We've just noticed that Servlet 3.1b03 onwards require JDK7[1].  I'm not sure if this is an intentional change since 3.1 b01 required only JDK5, but it will have implications for Grizzly and any applications and libraries which use Grizzly 2.3 HTTP Servlet onwards, since they will be required to use JDK7. Were you aware of these changes?
Yes, we were :)
Unfortunately Servlet 3.1 API introduced this dependency, so we have to follow if we want to support it.



Also, once 2.3 is released will it be possible to use it with Servlet 3.0 instead of 3.1? This question is less important if Servlet 3.1 is reverted back to supporting JDK6.
We'll try to compile/deliver 2.3 servlet module with JDK 1.6 as target. So it'll be possible to use Grizzly 2.3 servlet module and Servlet 3.0 API on JDK6 (I need to doublecheck that).


Finally, when is the expected release date for Grizzly 2.3?
We want to integrate 2.3 to Glassfish 4 and hardcode freeze for Glassfish 4 is next Monday... so we'll release 2.3 this week or early next week :)

Thanks.

WBR,
Alexey.

Reply | Threaded
Open this post in threaded view
|

Re: Grizzly 2.3 release date and Servlet dependencies

oleksiys
Administrator
Hi Matt,

fixed.
http://java.net/jira/browse/GRIZZLY-1467

WBR,
Alexey.

On 21.03.13 05:24, Matthew Swift wrote:
Hi Alexey,

Thanks for the quick response and the confirmation regarding JDK6/Servlet3.0  interop. I look forward to trying and testing Grizzly 2.3 very soon then! :-)

Matt



On 21 March 2013 09:11, Oleksiy Stashok <[hidden email]> wrote:
Hi Matt.


On 20.03.13 04:26, Matthew Swift wrote:
Hi there,

We've just noticed that Servlet 3.1b03 onwards require JDK7[1].  I'm not sure if this is an intentional change since 3.1 b01 required only JDK5, but it will have implications for Grizzly and any applications and libraries which use Grizzly 2.3 HTTP Servlet onwards, since they will be required to use JDK7. Were you aware of these changes?
Yes, we were :)
Unfortunately Servlet 3.1 API introduced this dependency, so we have to follow if we want to support it.



Also, once 2.3 is released will it be possible to use it with Servlet 3.0 instead of 3.1? This question is less important if Servlet 3.1 is reverted back to supporting JDK6.
We'll try to compile/deliver 2.3 servlet module with JDK 1.6 as target. So it'll be possible to use Grizzly 2.3 servlet module and Servlet 3.0 API on JDK6 (I need to doublecheck that).


Finally, when is the expected release date for Grizzly 2.3?
We want to integrate 2.3 to Glassfish 4 and hardcode freeze for Glassfish 4 is next Monday... so we'll release 2.3 this week or early next week :)

Thanks.

WBR,
Alexey.


Reply | Threaded
Open this post in threaded view
|

Re: Grizzly 2.3 release date and Servlet dependencies

Matthew Swift-3
Fantastic! Thanks Alexey. :-)


On 21 March 2013 19:42, Oleksiy Stashok <[hidden email]> wrote:
Hi Matt,

fixed.
http://java.net/jira/browse/GRIZZLY-1467

WBR,
Alexey.